[Fixed] Images not showing when rendering a form as pdf file

What I’m trying to do:
An app I am using to render a form with an image is not showing the image anymore, just saw this today, last time I used the app 4 days ago I didn’t have this issue
What I’ve tried and what’s not working:
Find the source of the issue: it seems that the PDFRenderer().render_form() is the source of the issue.
I tried an example app by anvil team : Generating PDFs with Python and Anvil and added an image to it to test it, and I got the same result, the image still not showing in the downloaded file

Clone link:
share a copy of your app

Any clue?

I too am experiencing this issue. App has worked great for months rendering images in PDF form, and just on the 15th this issue arose for me (co-worker that utilizes the app brought to my attention this morning). Hopefully it’s a minute issue that the Anvil team can shed some light on and review.

Thanks for reporting and the easy reproduction app.
We’ll get that fixed.

That should now be fixed.


We’re still experiencing this problem. In some cases we get images to populate using render_form(), but not always, and it’s not clear what causes the issue. Sometimes we get broken image icon where the image is supposed to be (even though the media object source of the image exists), and sometimes the component is just blank.

@saas_dev I’d suggest creating a minimal working example that demonstrates the issue - the bug here was fixed so you may have found a different bug.