[Fixed] Something went wrong rendering this part of the anvil editor -> can't edit my app

Hi! I’m just trying to edit an app but I am getting the following message (something went wrong rendering this part of the anvil editor) in the sidebar where I navigate between the forms to edit them so I can’t really edit my app at the moment. Seems to only be affecting one app (not sure how I should share this with you, can send by email if need be) - other apps are loading fine.

The problem started today - I did connect to uplink for the first time yesterday on this app. I don’t know if that’s of relevance (I have previously connected to uplink on other apps and never experienced this issue)

I’ve looked at some previous forum posts with similar issues and tried a combination of:

  1. Switching to an older commit
  2. Deselecting ‘Show in Toolbox’ for certain roles that are ticked
  3. Checking dependencies (app doesn’t have any)
  4. Changing the python version

but nothing has worked so far.

Could you please help me troubleshoot this?

1 Like

I’m seeing the same error in one of my apps. It appeared out of nowhere randomly without any changes in my app.
I suppose it might be some kind of error resulting from recent updates on anvil side.

thanks for reporting - moved to bug reports

could you try clearing the indexedDB for anvil and refreshing
we think that should fix it in the immediate term

dev tools → application → indexed-db → anvil → state → clear button

Screenshot 2024-03-21 at 22.34.51

then refresh the page

or just clearing the cache for the ide should also fix it

1 Like

This should now be fixed

thanks very much!! :blush:

Hi Stu,
I have the same exact problem as described above. Tried your suggestion of clearing the indexedDB but doesn’t work. Please take a look at the console log errors below, thanks!!


which part of the anvil editor is not rendering?
And was it working?
did it stop working?
did you change something locally?

Any other information will be helpful
You can also share the appId so we can take a look for you

Sadly, the whole thing. Right after I click the link to may app from anvil.works/build, a long period of loading spinner (2~3 mins) will commence, followed by the above errors. Initially, it was working just fine. I did change somethings but only on the drag and drop design. I thought it was caused by a growing size of database but looking up the console shows a different story. Sure! Anvil | Login

Thanks a lot Stu!