Restart New Tab does not fetch latest version

At first I thought I was going mad but it seems like some changes in the caching behavior results in debugging links not loaded with the up to date version.

Needless to say that this makes development harder that in would need to be.

1 Like

In my case, since 7 or 8 days, I need to restart the application twice to finally see my code-changes. It is really time-consuming and frustrating when expecting a behaviour that doesn’t occur due to some wrong caching. As mentioned after a second reload it works as expected. Please fix this issue - thanks :slight_smile:

I did try to reproduce this but I was unable. Whatever I tried the app loaded the relevant changes as expected.

Anymore insight you have would be helpful.

Steps to reproduce, including browser/OS.

I’ve experienced the same, not all the time, but a couple of times a day.

Using Edge mostly.

I know that sometimes if I make a change very quickly and refresh my app, then there is a yellow banner in the editor which says that the app has changed and needs a restart. But I am now in the habit of waiting a couple of seconds after any changes before refreshing my app, so all seems to update however when I run the app, the changes certainly haven’t pulled through.

When you say run the app. What does that mean here? Clicking run app in the IDE? Or running the published app? Or something else.

Running the app in the IDE.

1 Like

Why do you say refreshing instead of rerunning?

If you mean rerunning, I had this habit years ago. Now I can make any change and immediately press ctrl+enter, and the changes are always live.

For me it is when pressing this button:

One thing I noticed is this log which I haven’t seen before.
Not sure if its related though.

Hi folks,

Thanks for your patience - this should now be resolved. Please let us know in this thread if you’re still seeing the issue of old versions of your app showing up when running from the Anvil Editor!

1 Like

Hi @daviesian,

Yes we had no issues with reloading since the update.
Thanks for fixing this!

Hi Daviesian,

I am experiencing this issue.
It is appearing like a longterm (ie. >30 minute so far issue), and has previously been over a day.
For example, I have a print statement which says ‘Print this’, stuck when I have updated the code to say, ‘Print that’.

I am on Chrome, but have tried running the app in other browsers.
Also tried republishing, publishing specific commit instead of branch, changing branches and coming back etc.

This is a blocker for me at the moment.
Trying the software out and considering enterprise.

Kind Regards,

Hi @grantaustinpeace and welcome to the forum,

are you talking about the same issue?
This issue in this thread is about running the app from the IDE using the start button
and clicking Run in new tab

It seems like you’re saying your published app code isn’t updating as you’d expect?

1 Like

It was happening to me, too, yesterday and this morning. I’ve since refreshed the IDE’s browser tab (Chrome on Windows 10). Am about to update Chrome. Will let you know if the problem recurs.

Just letting everyone know.
The issue was because I was sending the same server call from two different forms, causing some complications.
It was entirely code related.

Thanks so much for your help.
My questions in the future will be more informed as a result of the troubleshooting required for me to resolve this.