[Fixed] Why write back is forced?

What I’m trying to do:
I have a textbox and have connected it to a data table through data bindings. What I want to do is validate this textbox so I don’t get incorrect values that don’t make sense in my table. It is also important that I don’t have this check as it would give me an error as I do not have my data table set up so that a form can change it (and I will not make it so).

What I’ve tried and what’s not working:
I have tried unticking the ‘Write back’ checkbox, but as soon as I click out of the textbox and reselect it again, to see its properties, it just re-checks itself, effectively always staying checked.

Code Sample:

# Nothing to see here

TextBox in question:

DataTable in question:

If you need me to show anything (e.g. images of something) else in this post for you to help me more, PLEASE ask in the comments ASAP.

Thanks for reporting - moved to bug reports

So this isn’t something that can be fixed within the span of 3 days from now? (please say that this will be a short and easy fix)

As a work around - make an edit to the binding code (add a space and hit backspace)
Then it should persist

1 Like

Thanks, that works. Also do you think it will be fixed within 3 days?

This should now be fixed (just reload the ide)

1 Like

I am still having this issue with checkbox component. It reselects the write back…

If you read @stucork’s comments you will find a temporary solution to the problem. This solution also worked for me.

Sorry about that - it was fixed. The fix regressed after a recent deploy.
Thanks for bringing it back to our attention - we’ll clean that up.

1 Like