[Fixed] Unable to Create App From Github

What I’m trying to do:

Use the Clone from Github option to clone an app from Github. The app in question is in a public repository I control and I have confirmed that I can commit changes to it (via the Github web interface, at least).

Update: I’ve tried this with:

  1. An app of my own that I downloaded via Git to my local computer and then pushed up to an empty Github repository, as a test.

  2. An app of someone else’s that I forked and then verified I could commit changes to it.

  3. A fork of Anvil Extras, since that seems like the gold standard of setting up Anvil apps on Github.

All generate the same error.

What I’ve tried and what’s not working:

Using the Clone from Github option in the main screen of the IDE. After authorizing Github for the repo (for all the repos, in case that made any difference), and clicking Clone it works for a few seconds and then gives me this error:

Since I can make changes to the app via Github the app isn’t in read only mode, so I’m not quite sure what’s causing Anvil to not be able to clone the app. I’m hoping that others who’ve done a lot of Github work will have a list of things to check that can cause issues that might trigger this too general error message.


The only issue I’ve had is the lack of a ‘master’ branch in the repo - which causes issues. I doubt that’s the case here since you tried with one of your apps created in Anvil.

I double-checked to be sure, but there is a master branch in all of the repos I tried to clone. Good thought, though! Good to know that can cause issues.

In case it provides relevant information to anyone, this is what the Anvil app settings look like on Github:

I tried it both on All repositories and on select repositories, and am seeing the same error.

Thanks for reporting - hopefully that should now be fixed


Confirmed, thanks for the quick fix!