[Fixed] Import uuid now in stdlib

I just learned that uuid is now in stdlib. So I change
from anvil_extras import uuid to import uuid
works in most browser but not in firefox.

Has anybody an idea why and how to work around?

Which version of Firefox are you using and what error do you get?
(If the error isn’t obvious it might be in the browser console)

1 Like

Error is: ModuleNotFoundError: No module named ‘uuid’

Ok try clearing your Firefox browser cache.

1 Like

Great, that worked.
Why was that?
Because I worked with Anvil in this browser?
If a customer gets to that, would he know what to do?

1 Like

We’ll consider this a bug report and see if we can reproduce the issue.

We just caught the same error → luckily on a qa environment but the feature relying on the uuid cannot be shipped as long as this bug persists.

It occured on a PWA in Chrome.

This is pretty dangerous since in our case it looks like it would have taken down random customer apps completly.

And for our users, clearing the browser cache is somewhere between rocket science and black magic :man_shrugging:

Its not super urgent for us, we excluded the feature from our next release but still some people might hit their head on this.

1 Like

In the past 5 years or so I have found getting users to at least hit Ctrl + F5 does the job 80% of the time…

(usually command + R on a mac)

To clarify, in this specific case reloading did not solve the issue above. If it had - I wouldn’t have commented - because as you said, this would not have been a big deal.

1 Like

@mark.breuss and @Aaron this should now be fixed.