[Fixed] Can't make changes in Beta editor with safari + Mac


I recently tried using the Beta editor with a new MacBook + safari but found that I can’t type anything. Mouse inputs register fine and strangely so does the delete key. The original editor works fine.

A search suggests there are some fixes on the server-side but no easy solution on the client-side.

This is probably more to do with me being unfamiliar with Macs but any help / suggestions would be very appreciated!


We actually don’t officially support safari for using the beta ide. Your best bet is to download a chromium based browser.

We will add it to our list of things to look at though (moved to bug reports)

Fair enough. Thanks very much.

r.e. a fix, stackoverflow suggests adding -webkit-user-select:text; to the input field of the form will fix it.

When you say can’t type anything. Which fields weren’t working for you?

I haven’t tried everything, but the main editor field and the REPL don’t work.
I can type into DataTable fields,

I was just searching through the bug reports cause I was having the same problem. The weird thing is that in the past I’ve written three different apps in Safari and it was fine. Went on holiday, and when I came back it stopped working. I am able to remote into another computer at work and make it work, but it’s not the best.

Not sure about OP, but I find when ever I’m trying to write code I can select with my mouse, delete it with the backspace button, but then no letter keys work, and hitting space bar brings me to the bottom of the code. So it seems to register certain keystrokes, but not all.

This morning I just happened to check and it was suddenly working again, but about 30 minutes later it stopped registering them again. I’ve tried in Firefox and Chrome as well, but nothing seems to work.

That’s in line with my experience too re the backspace and other keys.
I haven’t tried too much to get it to work. Some stackoverflow posts on similar issues with other website suggests there are workarounds to force Safari to focus on the relevant input form but they’re all fairly janky.

It’s on our list, I’m able to reproduce and we’ll be looking into.

There should be no problems with chrome, firefox or other chromium based browsers on Mac OS.
If there are please provide more details since I haven’t had issues using them (browser version and which os).

1 Like

This should now be fixed (Also editing on an iPhone is possible)
Thanks @ruaridh.macd for the tip on fixing the issue - saved me a lot of time!


Great! Glad to hear it helped

1 Like