[Beta] Clicking on the sorting buttons on the data table view does nothing

Clicking on the sorting buttons on the data table view does nothing:


Strange… It works for me. It’s just… Really weird with the dark theme.

I tried with different table in old apps and does nothing.
I tried with one table in one new app and it works.

Hum… I’ll definitely do more tests then.

So, I just tested on the same app and same Data Tables I tested yesterday and now the buttons don’t work, as you said it @stefano.menci . I think maybe was an update they released that unintentionally broke this functionality.

Hi both! Can you let me know the IDs of the apps where you’re seeing this behaviour?

Here are the two I have tried:


This is the one I tested:

It worked earlier in the beta, as I commented.

I added a few tables to the app ESBTDT7U4BMPNWUQ using the new editor, and now all the tables new and old can be sorted.

Hi @eli-anvil ! Any news about this? It still happens to me and it is a pain to navigate certain tables without any filtering AND sorting options to find certain rows.

It keeps happening.
Sometimes a table is sortable, then it becomes unsortable, then it’s back sortable. But mostly it’s unsortable.

As a workaround I learned to use the server console to query the database and do things like this:

import anvil.tables as tables
import anvil.tables.query as q
from anvil.tables import app_tables

app_tables.inventory.get(part='123')['qty'] += 10

for u in app_tables.users.search(tables.order_by('signed_up', ascending=False))[:10]:
    print(u['signed_up'], u['first_name'], u['last_name'])
1 Like

When I saw earlier that you fixed altering the data tables I tried, but it didn’t work for me. I’m still having to navigate thru the rows by clicking (annoyingly) in the load more button several times until I find the row I’m looking for, which usually is the last.

We could also have some sort of filtering in the DataTables section of the editor… I don’t know if it has in paid plans, though.

Hi both,

We’ve managed to reproduce this ourselves, and we’re investigating! Apologies for not updating you earlier.

1 Like

Thank you so much, this is such a minor bug, but it causes a lot of headaches hehehe!

Thanks for your time!

Don’t know how is the progress in this, but I managed to find an easy workaround to make the sorting buttons of a specific table work again:

Just change the number of rows displayed per page:
after you change it, the sorting buttons start working again and you can change the number of rows back to your preferred option.

Don’t know if this helps find / fix the problem, but at least can help those that are experiencing this for now.

(Another info: I always use 100 rows per page. Don’t know if this could be the original cause, but…)


Thanks, it helps me a lot, I have struggled with the issue for ages.

1 Like

Hi folks,

This should now be fixed! Please let us know if you still see the problem after refreshing the Editor (either Beta or Classic).

[Moved to bug reports]