Unable to clone Anvil Apps with Git

What I’m trying to do:

Clone any of my apps in the Anvil editor to my local system using git.

What I’ve tried and what’s not working:

  • Created a new Anvil App (G5X5H5QOWBTSEE7W)
  • Obtain the clone command from the View History dialog box
  • Run git clone ssh://c.cave-ayland%40imperial.ac.uk@anvil.works:2222/G5X5H5QOWBTSEE7W.git
  • Receive the below error
Cloning into 'G5X5H5QOWBTSEE7W'...
Unable to negotiate with port 2222: no matching host key type found. Their offer: ssh-rsa
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

I’ve tried adding/deleting ssh keys with the same error received each case. At the very least the documentation suggests I should be able to fall back to password authentication.

Clone link:


You might want to have a read of

1 Like

Ah, yep that would be it. Thanks!

@c.cave-ayland, it’s helpful if you mark owen’s reply as the solution:

A post was split to a new topic: Unable to clone Anvil app with Git on Mac/Windows