Stumped by Uplink: returns same error even when Uplink is disconnected

I kept getting an error from my uplink code that I did not understand (I thought I fixed it). However the error kept coming in. I got suspicious when the error pointed to code that did not exist anymore.
Then I completely disabled the uplink in the IDE. I still get the same error.

I have no idea how this can happen and also no idea how to fix it.

Check your server modules for a function with the same name.

Sometimes I forget that I have two functions with the same name, one on the uplink and one on a server module.

1 Like

Thx for the tip. It is not the cause of my problem. 100% sure because the stack trace contains mysql connector error code. So it’s definitely not server code.

Maybe an old machine still connected and running an older version?

I sometimes open PyCharm, debug an uplink, when it works I check it in to the git repository, go to the production server, pull it, start it and… the old one is still there, because I forgot PyCharm with the test version still running from the previous week.

I would love to have a dashboard that says what’s where :cry:

1 Like

No it’s new code. Rebooted my Mac and Macbook. Created new uplink code. Deleted uplink altogether.

Arggh, found the culprit. I had started the code at work, which I forgot. PyCharm had left the process hanging around.

So the take away from all this is:

  • remember what you have done
  • when you have uplink strangeness, reboot your systems
  • an uplink, once connected, stays connected
  • this is the case even when you change the uplink code and/or remove the uplink altogether (which looks like a (small?) security risk to me)
  • there is no way to find out which/how uplinks are connected to your server

We really need that dashboard!

2 Likes