Save always fails after external edits

What I’m trying to do:
I’m trying to work in the Anvil editor (any code change), after I’ve updated some files externally and pushed those changes to git (e.g., creating some classes and modules).

What I’ve tried and what’s not working:
Every single edit in the web editor causes an error to show up and my work isn’t saved.

I’ve tried refreshing but it seems the editor is irreversibly broken. The only solution is to check out an earlier state and revert to that. Whatever the error is, the error message doesn’t help at all and I would consider this a bug in the editor, that it doesn’t even tell me why the app couldn’t be saved.

I’m always careful to make changes (on a branch) in only one place at a time: the IDE, or my local PC, never both. Commit in one, pull/select in the other, before editing in the other. Maybe it’s overkill, but it helps keep me sane, and perhaps the IDE, too.

Can you select that specific pushed commit in the IDE?

I’ve figured that the problem is not that I’m making changes on one side or the other, but that the Anvil builder seems to have problems with the branch name feat/testing. Once I renamed the branch to testing, I was able to continue editing as normally. I guess a better error message would have helped a lot.

1 Like

@alexander.pacha thanks for bringing this up! That’s something that should definitely be changed/fixed, I’ll add it to our internal list and move the thread to Bug Reports