Issue installing custom packages Python 3.10 - Build Failed

What I’m trying to do:

Hi there,
I’ve been using the full Python 3.10 environment (beta) with the ability to add custom packages from PyPi. So far this has been working fine, but recently I needed to upgrade one of the packages I’m using to a later dev build, and the build is failing without explanation or logs.

What I’ve tried and what’s not working:

I’ve tried adding the dependency version manually to the version I need: 3.0.0a0 -thirdweb-sdk · PyPI - but I receive the following error without explanation or logs. It seems like this error happens either during or immediately after the ‘building base image’ step.

The only thing that works is leaving the version blank and defaulting to ‘latest’ but this (obvs) does not install the dev version I require. In fact, it looks like it installs version 2.1.0 which isn’t even the latest stable version (should in fact be 2.2.0).

If i try to install the version 2.2.0 manually (the latest stable version on PyPi - thirdweb-sdk · PyPI) it gives me the same error:

This leads me to believe that the issue is not with the dev package but rather with the anvil build installer.

The same error is thrown when I manually add version 2.1.0 - which is strange because this is the version that is installed succesfully when I install latest (see screenshot above of succesfull wheel build)

Any help would be greatly appreciated. This project is under a tight deadline ideally I get this working today.

Thanks in advance,



Hey everyone,

I am getting the same issue when installing the snowflake-connector-python[pandas] package.

** update: This appears to not work with any package I have tried installing.

Is this something which could be caused by version issues?
Can we see the build logs somewhere?



Same here.
I’m having troubles with some packages (not all).

I hope there is a fixable bug.

1 Like

Please see Python 3.10 Build pipeline issues? - #2

1 Like