Anvil Community Forum

End of Internet Explorer support

Hi all,

The week before last Internet Explorer was officially retired. If you, or any of your users, are still using IE, you really should upgrade to a new browser as a matter of urgency – IE11 will no longer receive security fixes, and using it on the Wild West of the Internet is a dangerous idea.

As for apps built with Anvil, our documentation states that we support all major browsers that are currently receiving security updates – and, as of the 15th of June, that no longer includes Internet Explorer! We haven’t yet released any changes that prevent apps from working in IE, but they will come.

If you’ve done any traditional web development (the HTML/JS/CSS stuff), you’ll know that supporting Internet Explorer has always been a drag. As we start to shed the compatibility layers we kept around for IE support, we’re looking forward to making Anvil faster, and being able to develop faster. Long live the modern web! :tada:


Postscript: If you have a burning need to support Internet Explorer users – which, again, is probably a bad idea – you can contact us to enquire about extended support with an Enterprise plan. Alternatively, you can self-host your apps and continue to use 1.7.x versions of the open-source App Server during your transition. Of course, then you’ll be using unsupported software to talk to unsupported software, so if you must do this we would suggest keeping it on a closed network and for as little time as possible!

9 Likes

Totally in favor of the decision and excited about the upcoming updates!

3 Likes