Cannot depend on dependency before other checks: anvil_extras dependancy issue

What I’m trying to do:

I am trying to clone my application and run in locally. I installed the anvil-app-server and all its dependancy and tried to run the application like this :

anvil-app-server --app eConsolto/ --origin http://local_host:8080

What I’ve tried and what’s not working:

but there is a missing anvil_extras dependency and I tried to add the following arguments

–config-file eConsolto/config-file.yaml
with content of the config-file.yaml to be like this:
“C6ZZPAPN4YYF5NVJ”: “/home/mohmah/projects/anvil_extras”

I also tried to run with this command param
–dep-id C6ZZPAPN4YYF5NVJ=./anvil_extras/

but I always keep getting the same error.

[WARN] Cannot depend on dependency before other checkseConsoltoC6ZZPAPN4YYF5NVJ{:branch “master”}

and the http://local_host:8080 shows

App dependency not found.

+1 on this issue. I’ve set up a clean anvil server environment, pulled down my app via git and when I run the server I also get Cannot depend on dependency before other with the browser showing:
This app may be misconfigured. The following error occurred:

App dependency not found

Hi, same issue here.
Have you found the solution yet?

I ran into this same error and was able to fix it.

App1 depended on App2 and App3.
App2 also depended on App3.

Collect all the dependency IDs and package_name values from the anvil.yaml from all apps and nested dependencies.

Be sure to use the value of the dep_id field and not the app_id.

The dep_id’s all begin with dep_. The package_name field is located in the resolution_hints section.

Use those values in your config.yaml or the --dep-id command-line arguments.


- dep_id: dep_abcd1234
  version: {dev: false}
  resolution_hints: {app_id: WXYZ4321, name: My App Dependency, package_name: my_dependency}

Config YAML

  "dep_abcd1234": "my_dependency" 

$ anvil-app-server --dep-id dep_abcd1234=my_dependency