[Beta] Allow to copy from the input line in the console

Both app and server consoles do not allow to copy text from the input line.

I very often select part of the expression I’m typing, press ctrl+c to copy it, then ctrl+v to paste it in another position in the expression.

It is frustrating not being able to do it, even more when my fingers do it without thinking and I end up corrupting my expression when pasting old clipboard content.

(I have the feeling that his is a regression, but I’m not sure)

2 Likes

Hi @stefano.menci,

I’ve tried recreating this in Chrome, Firefox and Safari and I can copy text from the console input. What browser are you using?

They may be obvious but could you write out some recreation steps please? I want to make sure I’m not missing something.

Thanks,
Ryan

Hi @ryan,

You are right, today it is possible :slight_smile:. Now it works and looks as expected:

image

When I posted this, the Paste item in the context menu was enabled, but the Copy was grayed out and the Ctrl+C didn’t work.

At a certain point I had a long expression that I really wanted to copy, so I right clicked on it, then clicked on Inspect, hoping to be able to copy from the developer tools, but it didn’t help because the text was polluted with the syntax highlighting classes. So I pressed enter, the uncomplete and wrong expression was executed and failed, but it was visible on the output area and I was able to use it to copy the parts that I wanted to copy.

I tried on other apps, and it was impossible to copy on all of them, so I created this post.

I have not tried on other computers. I don’t know if it was a temporary problem specific to this computer or it was on the Anvil side.

That’s typical. :sweat_smile:

I’ve tried some longer expressions but it still seems fine to me.

I’ll close this for now but let us know if it happens again and we will see what we can do.

Thanks for raising it and providing more information. It is useful - even if the bug is elusive.

1 Like