[Fixed] Anvil Extras Error With Routing Module

Hi all,

Suddenly started getting this error in my apps using the anvil extras routing module:

ExternalError: TypeError: Cannot assign to read only property 'in$repr' of object '[object Object]'

Nothing changed in my code.

Anyone else experiencing the same?

Thanks, Nico

Thanks for reporting, do you have any more info you could share?
The full stack trace?
A clone link or link to the live app (with reproduction steps)?

When did the error start?
Which OS/browser?
Have you tried other browsers?

1 Like

Hi @stucork,

I’ve run in to this error on all apps using the routing module. Other apps work fine. Is there a way for me to privately share a link with you to one of apps? It’s to my personal website, so I’d prefer not to share publicly.

This error started about 45min ago. Just before that, everything was working perfectly with no code changes between when it was working and when it broke.

Tried in both Chrome and Edge.

Sure just send me a private message on this forum.


I am experiencing the same issue.
I tried using an older version of anvil_extras, but none of them worked.
I created an issue on as well Anvil extras issue report
Let me know if I can help with additional informations.

Can confirm, this is happening on all apps using routing. Mine are pinned to the 2.1.0 version of Anvil Extras, so it’s not an update to the published version breaking something.

Here’s a clone link to my routing template example, where it also happens: Anvil | Login

And the live link: Forum: Hash Routing With Templates

And the stack trace:

ExternalError: TypeError: Cannot assign to read only property 'in$repr' of object '[object Object]'
at app/anvil_extras/routing/_router.py, line 388
called from app/anvil_extras/routing/_decorators.py, line 83
called from PagesPublic.Home, line 12
called from RouterPublic, line 9
called from Startup, line 5

Thanks for the additional reports, we should have a fix for you soon. Apologies for the disruption

1 Like

This should now be fixed, apologies again for the disruption.


Thank you for the quick solution. I can confirm that everything works fine now.

Thank you, all in order now.